13th August 2021

Remote Support Splashtop Connection issues

Connection attempts via Splashtop are not possible due to issue with SMS / Token codes. Our vendor servers are currently experiencing an issue. You might not be able to access your remote computers at this time. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience

UPDATE 10:00 The issue has been identified and a fix is being implemented.

UPDATE 10:20 A fix has been implemented and we are monitoring the results.

UPDATE 11:00 This incident has been resolved.