16th April 2021

Remote Support Splashtop SMS issues

Connection attempts via Splashtop are not possible due to issue with SMS codes. Our carrier is having issues that is affecting our customers’ ability to receive SMS codes, Auth and login. We will update once we have more information.

UPDATE 9:30 Our provider currently investigating ongoing issue.

UPDATE: 16:00 Connection sms codes should be now delivered properly.