20th August 2020

Remote Support Splashtop connection issues.

Splashtop connection issues.

Clients may experience connectivity issues using Splashtop application. We are investigating this issue.

Update 9:11 am. We have confirmed that the issues reported relate to recent platform upgrade on vendor side. Our vendor is currently working to stabilize service.

Update 9:40 am. Our vendor deployed fix to effected infrastructure. If you still experience connectivity issues- please reboot your device to apply new configuration changes.